Archives Recovery is not working

Incident Report for Wattsense

Resolved

Issue was resolved and archive requests that were made will be fulfilled automatically during the next few hours.
Posted Jul 27, 2023 - 12:36 CEST

Identified

We've identified, and are deploying a fix where archives recovery is not working properly.
Posted Jul 27, 2023 - 12:09 CEST
This incident affected: API.