Requests to the API to get the properties values were returning 401
Incident Report for Wattsense
Postmortem

Our latest version migrated the services that delivers property values to use reactive frameworks. During this migration, the validity check of the API signing message was by mistake altered. This made the query parameters mandatory for any request made to the API.

In some cases, the need for query parameters is not needed, in particular as when one wants to get the latest value of a property. Sadly, we noticed that we didn’t have a specific test for this scenario, hence missing this critical issue.

Posted Nov 09, 2023 - 19:33 CET

Resolved
Due to a recent version deployment, any request to the properties values API that did not provide a query parameter (such as calls to get the latest value of a property) returned 401.

The issue is now resolved.
Posted Nov 09, 2023 - 12:30 CET